Jump to content


Photo
- - - - -

Feature Slider Hiding Content


  • Please log in to reply
10 replies to this topic

#1 mjlyons13

mjlyons13

    Member

  • Members
  • PipPip
  • 26 posts

Posted 11 October 2011 - 06:48 AM

I managed to get a sidebar next to the feature slider on my homepage, however the sidebar is only "visible" in the part that's next to the feature. As you can see

Please Login or Register to see this Hidden Content

the links added to the sidebar widget are once again active as soon as they fall below the slider. I've tried using firebug, but can't figure it out. The custom CSS I used to get the slider there was: #feature-area, .feature-wrap, #feature_slider .fmedia, #feature_slider .fcontent, #feature_slider .text-bottom .fmedia .dcol-pad, #feature_slider .text-bottom .feature-pad, #feature_slider .text-none .fmedia .dcol-pad { height: 360px; width: 615px; } .home #feature_slider {width:615px; padding-left: 350px} .home #sidebar-wrap{margin-top:-400px;} Any help would be awesome!

#2 Danny

Danny

    Is Awesome!

  • Moderators
  • 16555 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 11 October 2011 - 09:35 AM

Hi,

The reason you have this issue is due to the padding-left:350px. So lets try this instead.

Can you please remove any custom code you have related to your feature slider on your hompage (please back this code up, just incase we may need it)

The add the following instead:

Please Login or Register to see this Hidden Content


That should do the trick hopefully, but if there are still issues, please reply so I can take a closer look, with the code I gave you.

#3 mjlyons13

mjlyons13

    Member

  • Members
  • PipPip
  • 26 posts

Posted 11 October 2011 - 06:00 PM

It still covers up the sidebar and looks a bit messy now. The lines goes all the way across instead of where it was, drawing a line through the sidebar.

#4 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 11 October 2011 - 06:19 PM

Okay... Your entire CSS for the feature slider being narrowed for the sidebar is missing a few bits and bobs. Check the correct code here:

Please Login or Register to see this Hidden Content



#5 mjlyons13

mjlyons13

    Member

  • Members
  • PipPip
  • 26 posts

Posted 11 October 2011 - 06:47 PM

I had to add the float right to get it looking someone normal. I still don't like the huge gap between the 2, or the line under the slider. Plus, clicking on the "Shop Dog Apparel" image takes me to the correct link, but eliminates the back feature. That wasn't happening before. Here's what I have #feature_slider div.default-features {width: 615px;} #feature-area {width: 615px} .home #feature-footer {width: 615px;} .home #feature_slider{width:615px;} .home #sidebar-wrap{margin-top:-400px;} .home #feature-area, .feature-wrap {width: 615px;} .home #feature-footer {width: 615px;} #feature_slider {width: 615px;} .home #feature_slider { float: right; }

#6 mjlyons13

mjlyons13

    Member

  • Members
  • PipPip
  • 26 posts

Posted 11 October 2011 - 06:50 PM

Fixed the image linking, does anyone have any ideas on how to remove that white area? I'm thinking I should just redesign the slider to be wider.

#7 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 11 October 2011 - 07:22 PM

Probably, but the slider itself doesn't seem to work and I think it's the result of the customization. You seem to have placed 3 separate posts (each slide is a custom type post), on one slide. I think that's blocking the transition of slides. However, I'll bump this up. You may want to find a slider that has that functionality built in.

#8 mjlyons13

mjlyons13

    Member

  • Members
  • PipPip
  • 26 posts

Posted 11 October 2011 - 07:36 PM

The slider works fine, I only have one slide in it right now. I'm not going to put together other slides unless they work. I've tested it as just a slider with other dummy slides and it works perfectly. It seems like a huge waste of time for me to make additional completed slides if I may have to change something. The slide is a media only slide, and I used an imagemap, that's why it appears as multiple images.

#9 mjlyons13

mjlyons13

    Member

  • Members
  • PipPip
  • 26 posts

Posted 11 October 2011 - 07:37 PM

If you want, I can add in the dummy slides so that you can observe the slider working properly.

#10 kastelic

kastelic

    Advocate

  • Members

  • 3081 posts
  • Country: Country Flag

Posted 11 October 2011 - 09:31 PM

So at this point you just want to remove the white area between the sidebar and the image slider? Besides either reducing the width of the page or increasing the width of the slider, I'm not sure what exactly you are needing to do here.
If you want to center the slider you could try this:

Please Login or Register to see this Hidden Content



#11 mjlyons13

mjlyons13

    Member

  • Members
  • PipPip
  • 26 posts

Posted 11 October 2011 - 10:25 PM

Thanks! I made it 826 px (which is the width of the content area in my one sidebar setting).