Jump to content


Photo

404 Error trying to make changes in EcoPro


This topic has been archived. This means that you cannot reply to this topic.
44 replies to this topic

#21 todd

todd

    Member

  • Members
  • PipPip
  • 18 posts

Posted 10 May 2010 - 12:39 AM

Didn't notice these errors in the theme window. Here is more: Notice: Undefined index: selectvalues in /home/tlamothe/public_html/toddlamothe/wp-content/themes/EcoPro/core/admin/option_templates.php on line 38 Notice: Undefined index: version in /home/tlamothe/public_html/toddlamothe/wp-content/themes/EcoPro/core/admin/option_templates.php on line 39 Notice: Undefined index: imagepreview in /home/tlamothe/public_html/toddlamothe/wp-content/themes/EcoPro/core/admin/option_templates.php on line 39 Notice: Undefined variable: serialize_subvalues in /home/tlamothe/public_html/toddlamothe/wp-content/themes/EcoPro/core/admin/option_templates.php on line 39 Notice: Undefined index: optionicon in /home/tlamothe/public_html/toddlamothe/wp-content/themes/EcoPro/core/admin/option_templates.php on line 39

#22 clint

clint

    Member

  • Members
  • PipPip
  • 12 posts

Posted 10 May 2010 - 01:04 AM

They look like the same warnings as yours. I changed the file back to false.

#23 clint

clint

    Member

  • Members
  • PipPip
  • 12 posts

Posted 10 May 2010 - 01:04 AM

I also disabled every plugin so that's not the issue. won't let me modify anything inside the feature setup.

#24 todd

todd

    Member

  • Members
  • PipPip
  • 18 posts

Posted 10 May 2010 - 02:16 PM

I have this installed in a brand new wordpress installation with no plugins, same issue. Maybe it is something at hostgator.

#25 cmunns

cmunns

    Advocate

  • Members

  • 6537 posts

Posted 10 May 2010 - 05:37 PM

We are looking into this problem further.

#26 arpowers

arpowers

    Founder

  • Administrators
  • 3270 posts

Posted 10 May 2010 - 05:41 PM

can you guys tell me if you have "magic_quotes_gpc" enabled in your php.ini file? (ask your host if you don't know) This should be disabled; but if it isn't I've patched or accounted for it in the upcoming versions.

#27 arpowers

arpowers

    Founder

  • Administrators
  • 3270 posts

Posted 10 May 2010 - 06:09 PM

Other information that is really useful is the information given by the `phpinfo()` function. I believe you can find this in your cpanel (if you're on HostGator) Since I believe this is related to a server variable being set.

#28 todd

todd

    Member

  • Members
  • PipPip
  • 18 posts

Posted 10 May 2010 - 06:44 PM

Here are some screenshots. Magic_quotes_gpc is disabled.
A picture is worth a thousand words:
The first 3 are php.ini quickconfig
Posted Image
Posted Image
Posted Image
Here is the PHP configuration
Posted Image

#29 clint

clint

    Member

  • Members
  • PipPip
  • 12 posts

Posted 10 May 2010 - 07:29 PM

I'll get a pic of mine as well, but it will be a couple hours before I can

#30 arpowers

arpowers

    Founder

  • Administrators
  • 3270 posts

Posted 10 May 2010 - 07:30 PM

Ok, Todd... can you email me some information so we can take a closer look at your server environment? I still can't see the problem, will have to do some testing w/ the code.

#31 arpowers

arpowers

    Founder

  • Administrators
  • 3270 posts

Posted 10 May 2010 - 07:38 PM

Also, do you guys have the permalinks options set in the wp admin?

#32 todd

todd

    Member

  • Members
  • PipPip
  • 18 posts

Posted 10 May 2010 - 07:42 PM

Permalinks are set on one server (my main blog), on the test one they are not set.

#33 clint

clint

    Member

  • Members
  • PipPip
  • 12 posts

Posted 10 May 2010 - 09:45 PM

don't understand what you mean by permalinks options arpowers, I have changed my permalinks setting to be more SEO friendly, as I do with all my blogs...is this what you mean?

#34 clint

clint

    Member

  • Members
  • PipPip
  • 12 posts

Posted 10 May 2010 - 09:47 PM

Posted Image

#35 arpowers

arpowers

    Founder

  • Administrators
  • 3270 posts

Posted 10 May 2010 - 10:00 PM

are you guys using mod_security anywhere on your server? (in an `.htaccess` file??)

Also, I will keep trying to figure this out; but have you guys contacted Hostgator to see if they can help figure out where these 404 pages are coming from?

#36 arpowers

arpowers

    Founder

  • Administrators
  • 3270 posts

Posted 11 May 2010 - 12:37 AM

after much testing on Todd's server; I've isolated what is causing the issue. For some reason, the server isn't allowing full urls (example: `http://www.someurl.com/` ) to be saved. My guess is it is a security setting somewhere. For example, remove all URLs in your options and it should save fine. Will you guys check with your host to see why this may be happening?

#37 todd

todd

    Member

  • Members
  • PipPip
  • 18 posts

Posted 11 May 2010 - 01:28 AM

I can do that. What change did you make to get it going. I noticed it is fixed now and I can save and what not. Also, doing a search, there was a suggestion to use a cpanel program: php.ini quickconfig -> Turn off register globals. I'll get in touch with hostgator and see if they can help as well.

#38 yizhan

yizhan

    Member

  • Members
  • PipPip
  • 14 posts

Posted 11 May 2010 - 05:25 AM

any progress about this issue? co'z i've got the same problem just this morning, i'm using iblogpro 4 theme and hostgator as well, i tried to change my theme to heatmap theme and got the same problem, it also got a 404 error when i tried to save theme option.

#39 arpowers

arpowers

    Founder

  • Administrators
  • 3270 posts

Posted 11 May 2010 - 05:52 AM

HOORAY!~ After working on this issue all day, I finally figured out exactly what's going on. Hostgator has added some security measures to fight the growing number of WP exploits out there... To fix: simply hit up Hostgator via chat support so they can whitelist the URL on your server.. (technically, this is all related to some mod_security setting on shared HG servers)

#40 arpowers

arpowers

    Founder

  • Administrators
  • 3270 posts

Posted 11 May 2010 - 05:56 AM

What change did you make to get it going. I noticed it is fixed now and I can save and what not.

I removed all the urls from the options...

again to fix, contact hostgator