Archived

This topic is now archived and is closed to further replies.

  • 0

404 Error trying to make changes in EcoPro

Question

Posted · Report post

I am having a really weird issue. I installed it yesterday, I made some edits to the features in EcoPro last night. Now when I go into the module to make changes, anytime I try to save when in the theme options or when I try to add a feature box I get a 404 error. I tried uninstalling and re-installing but that didn't help. I have screen shots of my steps if needed.

Share this post


Link to post
Share on other sites

44 answers to this question

Posted · Report post

first, did you disable plugins? Which files did you edit?

Share this post


Link to post
Share on other sites

Posted · Report post

I disabled the theme by selecting another theme. I then uninstalled the theme and then re uploaded it using the ftp option in wordpress themes. There error was happening by me clicking on EcoPro on the left admin bar then clicking save, (no changes being made) I can easily nuke my wordpress site and reload and re-add the module if you would like. The site I am working on is a backup of data from my existing site. Todd @ToddLamothe

Share this post


Link to post
Share on other sites

Posted · Report post

I nuked the wordpress site, nuked the db. Re-ftped Wordpress, configured it and then added EcoPro. Activated the theme and then went to save. Same problem as before.

Share this post


Link to post
Share on other sites

Posted · Report post

Then that to me sounds like the culprit is a customization somewhere that is saved in the DB, meaning you'll really have to retrace your steps and try to figure out what changes you could have made or plugins you could have added around the time the error started happening. Please provide a link to your website. Thanks, Bryan

Share this post


Link to post
Share on other sites

Posted · Report post

I wish there was customization. I took an empty directory on my website, uploaded vanilla Wordpress using FTP. Created an empty Mysql database. Ran the config, uploaded the the theme. That is all I have done so far. The link is www.ToddLamothe.com/toddlamothe I am going to try setting a sub-domain of test.toddlamothe.com and see if it yeilds better results.

Share this post


Link to post
Share on other sites

Posted · Report post

Making a sub-domain fixed it. so test.toddlamothe.com fixed the problem. Curious why it won't work in a directory, but whatever. Todd

Share this post


Link to post
Share on other sites

Posted · Report post

Sascha, Doesn't appear to be related. Sorry.

Share this post


Link to post
Share on other sites

Posted · Report post

I lied, it isn't fixed. I am just not getting an error message when I save. The options are not saving.

Share this post


Link to post
Share on other sites

Posted · Report post

Attempted adding it in on the main blog. I am receiving the 404 error there as well. So not a directory issue.

Share this post


Link to post
Share on other sites

Posted · Report post

Ya, this is a little strange. Could you post your php.ini settings here? Can you give us server information? (apache, php version etc...) WP version? Just to double check, no plugins are running correct?

Share this post


Link to post
Share on other sites

Posted · Report post

Wordpress 2.9.2 Here are the rest. Program Version Apache:2.2.15 CentOS: . cPanel: 11.25.0-RELEASE Curl:7.12.1 MySQL 5.1.30 phpMyAdmin 3.2.4 Python: 2.4.3 Program Version Perl: 5.8.8 PHP: 5.2.4 ionCube Loader: 3.3.14 Zend Optimizer:3.3.9 Ruby:1.8.7 Rails: 2.3.5 OpenSSL: 0.9.8e-fips-rhel5 Not sure where to find php.ini, I am hosting on hostgator. No plugins running, hello dolly and askismet is there but unactivated. I have an admin account that gives me the 404 error. Using the admin account removes the 404 but the settings don't save. Pressing Save sends me back to the main EcoPro page. I did this have this working the other night when I bought it. I started customizing my blog but the next day it stopped behaving. I have since deleted that setup and created this really vanilla setup for testing.

Share this post


Link to post
Share on other sites

Posted · Report post

so I guess the question is... what were the customizations? Do you have something you suspect caused it? Try this: in init_core.php change `define('DEBUG', false);` to `define('DEBUG', true);` and see if you get some warnings...

Share this post


Link to post
Share on other sites

Posted · Report post

I just started having the same problem! I already had some features set up, so everything was working fine just a few weeks ago. Yet, today I tried to save a change to one of my features and I keep getting a 404 message and it does not save the changes..

Share this post


Link to post
Share on other sites

Posted · Report post

by the way, I'm using the iblogpro 4 theme

Share this post


Link to post
Share on other sites

Posted · Report post

I'm also using hostgator

Share this post


Link to post
Share on other sites

Posted · Report post

arron, I made the changes you suggested in the file editor and everything went crazy and some warning cam up, so I changed in back to false

Share this post


Link to post
Share on other sites

Posted · Report post

The first night, I downloaded it, installed it and I took the logo out, made a feature in the red area and two feature boxes. Was able to click save and see changes. Then I went to bed, the next morning, I could make no changes. The 404 errors started the next morning. Add a feature, adding a logo, all the same. Here is the debug info: the tdomain spot is assuming I think is correct. Notice: Use of undefined constant TDOMAIN - assumed 'TDOMAIN' in /home/tlamothe/public_html/toddlamothe/wp-content/themes/EcoPro/config/config_widgets.php on line 10 Notice: Use of undefined constant TDOMAIN - assumed 'TDOMAIN' in /home/tlamothe/public_html/toddlamothe/wp-content/themes/EcoPro/config/config_widgets.php on line 45 Notice: Use of undefined constant TDOMAIN - assumed 'TDOMAIN' in /home/tlamothe/public_html/toddlamothe/wp-content/themes/EcoPro/config/config_widgets.php on line 77 Notice: Use of undefined constant TDOMAIN - assumed 'TDOMAIN' in /home/tlamothe/public_html/toddlamothe/wp-content/themes/EcoPro/config/config_widgets.php on line 108 Notice: Use of undefined constant TDOMAIN - assumed 'TDOMAIN' in /home/tlamothe/public_html/toddlamothe/wp-content/themes/EcoPro/config/config_sidebars.php on line 5 Notice: Use of undefined constant TDOMAIN - assumed 'TDOMAIN' in /home/tlamothe/public_html/toddlamothe/wp-content/themes/EcoPro/config/config_sidebars.php on line 14 Notice: Use of undefined constant TDOMAIN - assumed 'TDOMAIN' in /home/tlamothe/public_html/toddlamothe/wp-content/themes/EcoPro/pro/sidebars_pro.php on line 5 Notice: Use of undefined constant TDOMAIN - assumed 'TDOMAIN' in /home/tlamothe/public_html/toddlamothe/wp-content/themes/EcoPro/pro/sidebars_pro.php on line 13 Notice: Use of undefined constant TDOMAIN - assumed 'TDOMAIN' in /home/tlamothe/public_html/toddlamothe/wp-content/themes/EcoPro/pro/sidebars_pro.php on line 22 Notice: Use of undefined constant TDOMAIN - assumed 'TDOMAIN' in /home/tlamothe/public_html/toddlamothe/wp-content/themes/EcoPro/pro/sidebars_pro.php on line 30 Notice: Use of undefined constant TDOMAIN - assumed 'TDOMAIN' in /home/tlamothe/public_html/toddlamothe/wp-content/themes/EcoPro/pro/sidebars_pro.php on line 38 Notice: Use of undefined constant TDOMAIN - assumed 'TDOMAIN' in /home/tlamothe/public_html/toddlamothe/wp-content/themes/EcoPro/pro/sidebars_pro.php on line 46 Notice: Use of undefined constant TDOMAIN - assumed 'TDOMAIN' in /home/tlamothe/public_html/toddlamothe/wp-content/themes/EcoPro/pro/sidebars_pro.php on line 54 Notice: Trying to get property of non-object in /home/tlamothe/public_html/toddlamothe/wp-content/themes/EcoPro/core/admin/options.class.php on line 216

Share this post


Link to post
Share on other sites

Posted · Report post

Clint, what do the warnings say? Are they the same ones?

Share this post


Link to post
Share on other sites

Posted · Report post

Didn't notice these errors in the theme window. Here is more: Notice: Undefined index: selectvalues in /home/tlamothe/public_html/toddlamothe/wp-content/themes/EcoPro/core/admin/option_templates.php on line 38 Notice: Undefined index: version in /home/tlamothe/public_html/toddlamothe/wp-content/themes/EcoPro/core/admin/option_templates.php on line 39 Notice: Undefined index: imagepreview in /home/tlamothe/public_html/toddlamothe/wp-content/themes/EcoPro/core/admin/option_templates.php on line 39 Notice: Undefined variable: serialize_subvalues in /home/tlamothe/public_html/toddlamothe/wp-content/themes/EcoPro/core/admin/option_templates.php on line 39 Notice: Undefined index: optionicon in /home/tlamothe/public_html/toddlamothe/wp-content/themes/EcoPro/core/admin/option_templates.php on line 39

Share this post


Link to post
Share on other sites

Posted · Report post

They look like the same warnings as yours. I changed the file back to false.

Share this post


Link to post
Share on other sites

Posted · Report post

I also disabled every plugin so that's not the issue. won't let me modify anything inside the feature setup.

Share this post


Link to post
Share on other sites

Posted · Report post

I have this installed in a brand new wordpress installation with no plugins, same issue. Maybe it is something at hostgator.

Share this post


Link to post
Share on other sites

Posted · Report post

We are looking into this problem further.

Share this post


Link to post
Share on other sites

Posted · Report post

can you guys tell me if you have "magic_quotes_gpc" enabled in your php.ini file? (ask your host if you don't know) This should be disabled; but if it isn't I've patched or accounted for it in the upcoming versions.

Share this post


Link to post
Share on other sites