• 0
Sign in to follow this  
Followers 0

Pagelines isn't using my styles

Question

Posted · Report post

Hello, My Setup: Ubuntu 10.04LTS - Wordpress 3.2.1 - PlatformPro 1.5.2 - PlatformBase 1.4.1 (activated). My wordpress folders (and subfolders - including themes): group www-data, 775 access. No active plugins. Just the default ones installed. I can save my settings on Design Control and Typography screens. Although all my changes are being saved, these changes aren't being written into any CSS file. Those are the files sent to my browser (in this order): http://www.zerobit.com.br/wp-includes/css/admin-bar.css?ver=20110622 http://www.zerobit.com.br/wp-content/themes/platformpro/pro/pro.css?ver=153-031411192440 http://www.zerobit.com.br/wp-content/themes/platformbase/style.css?ver=153-052111200528 http://www.zerobit.com.br/wp-content/themes/platformpro/css/dynamic.css?ver=153-090211221542 http://www.zerobit.com.br/wp-content/themes/platformpro/style.css http://www.zerobit.com.br/wp-content/themes/platformpro/css/common.css I've looked those files but couldn't find any occurrence of: #c231c2 (a color I set in the design screen). After messing around, I've tried installing the free platform theme (the one downloadable from worpress.org) and it works! But I want to use the Pro/Base version Any clues ?

Share this post


Link to post
Share on other sites

23 answers to this question

  • 0

Posted · Report post

can we see the site in question?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Sure: www.zerobit.com.br

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

[code] HTTP/1.1 200 OK => Date => Mon, 05 Sep 2011 16:21:27 GMT Server => Apache/2.2.14 (Ubuntu) Last-Modified => Fri, 02 Sep 2011 22:15:42 GMT ETag => "239b0-2c5d-4abfcb3b5ff80" Accept-Ranges => bytes Content-Length => 11357 Vary => Accept-Encoding Connection => close Content-Type => text/css [/code] Thats the headers for the css file, and if you open it its for 1.5.2 not 1.5.3 This would suggest your server is somehow caching CSS files. Sett css to inline in the platform settings to disable css file creation.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I don't think it is a cache issue because other themes (platform free included) aren't affected. Just to verify if those files are being updated I checked current time (Mon Sep 5 12:57:38 EDT 2011) and pressed Save Options. Then went to console and typed ls -la: platformbase: -rwxrwxr-x 1 victor www-data 3746 2011-05-21 16:05 style.css platformpro: -rwxrwxr-x 1 victor www-data 35493 2011-09-02 18:15 style.css platformpro/css: -rwxrwxr-x 1 victor www-data 4592 2011-05-05 19:04 common.css -rwxrwxr-x 1 victor www-data 11357 2011-09-02 18:15 dynamic.css -rwxrwxr-x 1 victor www-data 109 2011-01-20 22:11 ie7.css This output suggests that none of them are being updated.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

i know they being written the the filesystem, but the webserver is NOT sending the latest file http://www.zerobit.com.br/wp-content/themes/platformpro/css/dynamic.css?ver=153-090211221542 This is 1.5.2 NOT 1.5.3 it is being cached, do you have a reverse proxy?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

No reverse proxy. I don't know if it helps: http://www.zerobit.com.br/phpinfo.php platformpro.zip (downloaded today from members area) contains this outdated dynamic.css (1.5.2)

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

The one in the zip will be overwritten anyway if you open the css file on the server in nano whats he version there?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

that is exactly what I did. Unziped then: /downloads/platformpro/css$ vi dynamic.css /* PageLines - Copyright 2011 - Version 1.5.2 */ /* Set Type --------------- */ h1, h2, h3, h4, h5, h6, .site-title{font-family:Georgia, "Times New Roman", Times, serif;} body, .font1, .font-primary, .commentlist{font-family:Georgia, "Times New Roman", Times, serif;} .font2, .font-sub, ul.main-nav li a, #secondnav li a, .metabar, .subtext, .subhead, .widget-title, .post-comments, .reply a, .editpage, #pagination .wp-pagenavi, .post-edit-link, #wp-calendar caption, #wp-calendar thead th, .soapbox-links a, .fancybox, .standard-form .admin-links, #featurenav a, .pagelines-blink, .ftitle small{font-family:"Lucida Grande", "Lucida Sans", "Lucida Sans Unicode", sans-serif;letter-spacing:0.10em;text-transform:uppercase;} (...)

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Yes i KNOW the file in the zip is 1.5.2 the file updates when you refresh the page. Ignore the zip completly, open -rwxrwxr-x 1 victor www-data 11357 2011-09-02 18:15 dynamic.css this file i upposed to update.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

The same output... I just pressed Save Changes and I can see from the modification date that this file wasn't updated. /var/www/zerobit/wp-content/themes/platformpro/css$ vi dynamic.css /* PageLines - Copyright 2011 - Version 1.5.2 */ /* Set Type --------------- */ h1, h2, h3, h4, h5, h6, .site-title{font-family:Georgia, "Times New Roman", Times, serif;} body, .font1, .font-primary, .commentlist{font-family:Georgia, "Times New Roman", Times, serif;} .font2, .font-sub, ul.main-nav li a, #secondnav li a, .metabar, .subtext, .subhead, .widget-title, .post-comments, .reply a, .editpage, #pagination .wp-pagenavi, .post-edit-link, #wp-calendar caption, #wp-calendar thead th, .soapbox-links a, .fancybox, .standard-form .admin-links, #featurenav a, .pagelines-blink, .ftitle small{font-family:"Lucida Grande", "Lucida Sans", "Lucida Sans Unicode", sans-serif;letter-spacing:0.10em;text-transform:uppercase;} input[type="text"], input[type="password"], textarea, #dsq-content textarea{font-family:Courier, Verdana, sans-serif;} (...)

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Well for whatever reason it cant write out to that file. So please enable inline CSS

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Inline CSS works but is unacceptable because will increase my site's size, which will not only consume more bandwith but also take long to download. (I've tried saving both with ajax enabled and disabled)

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

How much bandwidth do you have?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I'm not concerned with bandwidth but with download times of my visitors. I don't think there is any problem with my setup because platform free works. But i was very interested in pro features. If I cant get this to work, I'd like to ask for refund and delete my platform pro installation.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

But the free version is identical to the pro version in that respect. I dont know why your install cannot write to that file. Have you tried ebaling WP_DEBUG and checking the server logs? You have apache running as www-data are you sure it has rw permissions for that folder?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Yes. Yesterday I also tried chmod 777 and didnt work either.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I've just activated platform free. If you visit (www.zerobit.com.br), all changes are ok. If I come back to Pro, no modifications are written.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

This is NOT a theme issue, the web server obviously cannot write to the dynamic.css file, I cant say why, its your server.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

How can I ask for refund ? Thanks

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Please e-mail hello@pagelines.com.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thanks Catrina. I've sent them an email. =)

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I'm running: Ubuntu 10.04 LTS 32 bits on a Linode VPS. I have root access. Installed PHP, Apache, MySQL from Ubuntu repositories. Downloaded Wordpress 3.2.1 from Wordpress.org. Extracted wordpress. Didn't activated any plugins. Downloaded PlatformPro from members area. Extracted into Themes. Chmod everything in Apaches dir (/var/www) to 777 (chmod -R 777 /var/www) It's definitely not an issue with my Server. If so, I'd like you to point me out at is wrong.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Who is the web folder owned by? Your running apache in mod_php mode, it runs apache under www-data not the owner of the files, this is nearly always the problem. Why are you running mod_php anyway? To make use of an object cache maybe? I dont know you dont seem to have one compiled in. If your running debian have you concidered mod_itk? it runs apache under the username of the folder owner, or ultimately just use suphp/phpcgi like everybody else. Im not saying it defiantly is your server misconfigured but the fact that thousands of people using shared hosting on cpanel etc dont have problems, yet you on a vps do. I dont mind helping you out, ive been a server admin for years, i have debian experience as well as centos/cpanel, so hit me up on skype if you like.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0