Jump to content


Photo

How to remove page content/sidebars on feature page in WhiteHouse Pro


  • Please log in to reply
14 replies to this topic

#1 idahobusinesscouncil

idahobusinesscouncil

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 17 August 2011 - 04:24 PM

On my home page I only want to have the Menu, Logo, Feature Slider, the Three Feature boxes, and the footer stuff. I do not want to have the sidebar or the page content. This was easy to remove in platform but is not so easy in Whitehousepro. How do I do it?

#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 17 August 2011 - 05:15 PM

In the settings for WHPro, on the Pages and Posts settings, you should see some check boxes to include things like sidebars. Make sure that's unchecked and see if it helps. Let us know if it doesn't.

#3 idahobusinesscouncil

idahobusinesscouncil

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 17 August 2011 - 07:33 PM

I do not have that option here is what I have: WP Title Author Info Post Thumbnail Placement Post Excerpt Placement Full Post Content Placement Features on Blog Posts Footer Link Meta Bar Background Color Meta Bar Text Color Meta Bar Link Color Footer Social Links Text Footer Sharing Icons

#4 kastelic

kastelic

    Advocate

  • Members

  • 3081 posts
  • Country: Country Flag

Posted 17 August 2011 - 09:22 PM

Is the home page your blog page? Which template are you using, can't you just use the Full-Width Page template to hide the sidebar?

#5 idahobusinesscouncil

idahobusinesscouncil

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 26 August 2011 - 06:34 PM

You can view the problem at idahobusinesscouncil.org, it is on the home page and you can still see the crap on the bottom that I want gone. It is where content would generally go. For example you can see the lines from where the title would be and the gray for the column on the side. Thanks

#6 Jenny

Jenny

    Advocate

  • Unicorn Store Dev

  • 2924 posts
  • LocationWV
  • Country: Country Flag

Posted 27 August 2011 - 01:14 AM

Just to verify, you created a page called "Home" and then in Wordpress -> Settings -> Reading, you selected the radio button next to static page and selected "Home" under "Front Page" correct? In addition, there is some hidden text underneath the lines you mentioned above. The text says "test" but you can't see it presumably because the text is white. Do you know what that is?

#7 diretornak

diretornak

    Advanced Member

  • Members

  • 88 posts
  • LocationSao Paulo, Brasil
  • Framework Version:Always Latest
  • Country: Country Flag

Posted 05 September 2011 - 04:56 PM

I am having the same problem. I want to remove the content and sidebars from my feature page template, but i dont find the option in the admin panel...

#8 billwsashnet

billwsashnet

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 05 September 2011 - 07:26 PM

Hello diretornak, I used the following CSS on my site: .page-id-2 #maincontent {width:100%;} .page-id-2 #maincontent {height:1px;} .page-id-2 #sidebar {display:none;} Change the page id to whatever you page id is. Remember, you must have a static front page. Hope this helps you. Otherwise please disregard all after "hello." Bill

#9 sophiemoon

sophiemoon

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 08 September 2011 - 08:19 AM

Hello, I'm trying to do the exact same thing on my homepage and have entered in that code but nothing has changed. http://nationalrecov...ydesigns.com.au I've come from using Platform Pro which is so easy to work so am getting a bit frustrated with this theme ugh. All I want to display on the homepage is the feature, the navigation + social media icons and the bottom widget with the address line. I don't want any content, I don't want the sidebar widget with the RSS feed. Thanks for your help, Sophie.

#10 Jenny

Jenny

    Advocate

  • Unicorn Store Dev

  • 2924 posts
  • LocationWV
  • Country: Country Flag

Posted 10 September 2011 - 01:03 AM

@sophiemoon It looks like you got this working. I visited your blog and don't see any content or sidebars.

#11 glee

glee

    Member

  • Members
  • PipPip
  • 14 posts

Posted 29 September 2011 - 09:08 PM

I was able to fix this issue using a plugin called Custom Sidebar.

#12 kelly

kelly

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 03 October 2011 - 08:43 PM

Sophie, I am having the same problems you were having with your site. How were you able to fix your problem? Your site looks really great!

#13 c4talyst

c4talyst

    Member

  • Members
  • PipPip
  • 12 posts

Posted 10 October 2011 - 12:38 AM

I posted another thread about this before seeing this one. I have the same need as Sophie.

#14 c4talyst

c4talyst

    Member

  • Members
  • PipPip
  • 12 posts

Posted 10 October 2011 - 02:24 AM

I fixed this on my site; you can read about it here: http://www.pagelines...homepage#Item_3

#15 sophiemoon

sophiemoon

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 11 October 2011 - 12:30 AM

@Kelly - sorry for the delayed reply! My memory is a little hazy on how I did this. I remember I tried out a couple of things and then all of a sudden it was fixed. Webmaster magic lol. Anyway, so I looked through the settings and I have my home page set up but it doesn't have any content and I have selected the "full page content" template so the page is the whole width and no side bar. Under settings > reading I have set the 'home' page to be the static landing page. Then I looked under my custom code and I have the following written. (this is "theme options > custom code") .page-id-136 #maincontent {width:100%;} .page-id-136 #maincontent {height:1px;} .page-id-136 #sidebar {display:none;} .post-footer .left { display:none; } --------------------------------------------------- Particularly, highlighting the 2nd rule - #maincontent {height: 1px;} this brings the size of the main content area on the front page to only 1px high which is what hides the extra 'space'. Let me know if that helps you! The client was pleased with the website so I'm happy to hear you liked it as well! :)