Jump to content


Photo

how do I turn off commenting on "pages"


  • Please log in to reply
12 replies to this topic

#1 szool

szool

    Advocate

  • Members
  • PipPipPipPipPip
  • 279 posts

Posted 31 July 2011 - 05:27 PM

every page has commenting enabled, I only want comments on posts, not pages. Thanks! http://citizenmediagroup.com

#2 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 31 July 2011 - 06:31 PM

You need to open the Page editor for those pages and uncheck "Allow Comments" under the Discussion section.

#3 szool

szool

    Advocate

  • Members
  • PipPipPipPipPip
  • 279 posts

Posted 31 July 2011 - 08:23 PM

for every page.... no option to do them all at once?

#4 szool

szool

    Advocate

  • Members
  • PipPipPipPipPip
  • 279 posts

Posted 31 July 2011 - 08:30 PM

also I have no "discussion" section in the page editor....

#5 Kate

Kate

    Advocate

  • Members
  • 3039 posts

Posted 01 August 2011 - 03:59 PM

At the top of your screen, you'll see a small box that says "Screen Options". Click that, and a menu will dropdown. Select to show the "Discussion" area.

#6 szool

szool

    Advocate

  • Members
  • PipPipPipPipPip
  • 279 posts

Posted 02 August 2011 - 01:21 AM

ok... comments is NOT checked yet they still appear on the page.

#7 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 02 August 2011 - 02:35 AM

Would you prefer to just hide the comment section using CSS for now (until a solution is found for why the comments are still showing up)?

#8 szool

szool

    Advocate

  • Members
  • PipPipPipPipPip
  • 279 posts

Posted 03 August 2011 - 02:48 AM

sure.... sounds ok to me!

#9 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 03 August 2011 - 02:51 AM

Okay, please add this CSS to your CSS rules box in the theme options:
 #maincontent body.page div.commentform {display: none;}


#10 szool

szool

    Advocate

  • Members
  • PipPipPipPipPip
  • 279 posts

Posted 03 August 2011 - 04:08 AM

that has no effect... not sure why.

#11 kastelic

kastelic

    Advocate

  • Members

  • 3081 posts
  • Country: Country Flag

Posted 08 August 2011 - 11:23 PM

Try:
 .page .awpcomments, .page commentsform {display:none}


#12 fridgefullofbeer

fridgefullofbeer

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 03 September 2011 - 08:14 AM

open the page you want to edit. at the very top of the screen you will see a grey tab that says "Screen Options." Click that, then make sure "Discussion" is checked. The discussion option box has a check box for "Allow comments."

#13 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 03 September 2011 - 01:42 PM

When you create a page or post, you have the option then to allow comments and pings for that post/page. This is WordPress core functionality.