Jump to content


Photo

Problem with feature page as front/blog page


  • Please log in to reply
34 replies to this topic

#21 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 04 August 2011 - 02:38 AM

I think Jimmy (kastelic) thought you were using PlatformPro, not StationPro, so that's why the settings are different. You can hide the feature set in other pages by using custom CSS. You just need to know the page IDs for the pages where you want the feature slider to be hidden so they can be used in the CSS.

#22 infojerrytattoocom

infojerrytattoocom

    Advanced Member

  • Members
  • 51 posts
  • Country: Country Flag

Posted 04 August 2011 - 02:52 AM

I tried to put that code in Custom CSS, of course I changed the id of the page and the ID of the feature but nothing changed, the feature slides were still there, also in other pages :/

#23 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 04 August 2011 - 02:53 AM

You need to make sure the code looks like this:

 .page-id-15 #feature,
	.page-id-16 #feature,
	.page-id-17 #feature {display:none}


#24 infojerrytattoocom

infojerrytattoocom

    Advanced Member

  • Members
  • 51 posts
  • Country: Country Flag

Posted 04 August 2011 - 04:31 AM

I did but if I use that code every feature in the specified page disappear. I don't want to eliminate every feature slides, I want just to don't show the feature slides that are in my home/posts page. if I use: .page-id-165 #feature {display:none} every feature slides disappear if I try to change the code nothing happen...

#25 kastelic

kastelic

    Advocate

  • Members

  • 3081 posts
  • Country: Country Flag

Posted 04 August 2011 - 10:08 PM

Oh, so you want the slider on those pages you just want to omit specific slides? If you go to edit each feature slide, theres a field called "Display Pages", where you can choose with page id's you want to display that feature. Sorry for the confusion.

#26 infojerrytattoocom

infojerrytattoocom

    Advanced Member

  • Members
  • 51 posts
  • Country: Country Flag

Posted 04 August 2011 - 11:54 PM

yes, that's right, and I knew it but I have some problem here, my front page is also my posts page and as "cmunns" said: [the PAGE ID option for the feature slides isn't possible with the blog page bc the blog page has no actual page meta ID...], say that; I have to find a way to avoid that the feature set of my home page appears also on other pages with a feature template. To be clear as much as I can: my home/posts page: http://jerrymagni.com/wp/ is using a feature-template and have this feature slides (home1, 2 and 3). which I can not assign a page ID my portfolio: http://jerrymagni.com/wp/portfolio/ is using a feature-template and have assigned the feature slides "port1", 2 and 3 but, because I cannot assign a Page ID to the slides of the home page, I can see also the feature slides of the home page and it's what I want to avoid. I'm totally new to the CSS scripting, so I don't know how to proceed; even if I'm pretty sure the solution is just under the corner Can you help me?

#27 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 05 August 2011 - 02:43 AM

Ah, okay, I understand now. Here is CSS you should try instead:

 .page-id-15 #feature #home1 {display:none}

This will hide the home1 feature on your homepage slider. It can be changed so that it hides the feature in the slider in your other pages. Can you please post a link to a page where you want a specific slide to be hidden?

#28 infojerrytattoocom

infojerrytattoocom

    Advanced Member

  • Members
  • 51 posts
  • Country: Country Flag

Posted 05 August 2011 - 03:01 AM

I put that code in Custom CSS but nothing happen :(

#29 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 05 August 2011 - 03:03 AM

Can you post a link to the page where you want the feature slide to be hidden? Also, can you provide the name of the feature slide that you want to hide?

#30 infojerrytattoocom

infojerrytattoocom

    Advanced Member

  • Members
  • 51 posts
  • Country: Country Flag

Posted 05 August 2011 - 03:38 AM

http://www.jerrymagni.com/wp/portfolio (page ID 165) home1 home2 home3

#31 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 05 August 2011 - 03:31 PM

 body.page-id-165 #featurearea #home1, body.page-id-165 #featurearea #home2, body.page-id-165 #featurearea #home3 {display: none;}


#32 infojerrytattoocom

infojerrytattoocom

    Advanced Member

  • Members
  • 51 posts
  • Country: Country Flag

Posted 05 August 2011 - 04:24 PM

still not working :(

#33 kgstew

kgstew

    Super Member

  • Members
  • 173 posts
  • Country: Country Flag

Posted 05 August 2011 - 10:00 PM

what happens if you edit /pro/template_feature.php and add this code to the top:

 
	<?php if(is_home()) {
	
	$dpost = $post;
	$post->ID = 9999;
	
	} ?>

then use a page id of 9999 in feature setup.. .

then at the end of the feature template (above) add this to set back the $post variable:
 
	<?php if(is_home()) {
	
	$post = $dpost;
	
	} ?>


#34 infojerrytattoocom

infojerrytattoocom

    Advanced Member

  • Members
  • 51 posts
  • Country: Country Flag

Posted 05 August 2011 - 10:39 PM

Hallelujah!!! You're the man Finally the problem is solved. Thank you so much :)

#35 infojerrytattoocom

infojerrytattoocom

    Advanced Member

  • Members
  • 51 posts
  • Country: Country Flag

Posted 13 April 2012 - 04:48 PM

Hey kgstew, I'm still working on the same website, I know it's a while but I'm on and off on that site. Anyway, your code works to show the feature box in my post/homepage but it disable the thumbnail in the first post of the page, any suggestion? the page is here: http://www.jerrymagni.com/wp