Jump to content


Photo
- - - - -

Adjust padding between main column and sidebar?


  • Please log in to reply
6 replies to this topic

#1 kreilly

kreilly

    Member

  • Members
  • PipPip
  • 13 posts

Posted 21 July 2011 - 03:36 AM

Looking to increase the padding--I believe default is 26px--between the main column and the right sidebar in the one-sidebar layout. I'd like to make the main column smaller, in particular, while keeping the right column a fixed size, so I'm guessing increasing padding is the best way to do this. What selector would this be? Also, I'm using the PlatformBase child theme. The code for the padding adjustment will go in the style.css file, correct? Thanks

#2 cmunns

cmunns

    Advocate

  • Members

  • 6537 posts
  • Country: Country Flag

Posted 21 July 2011 - 07:12 PM

Yes add this CSS and adjust the values accordingly. `.mcolumn-pad {padding:0px 0px 0px 0px;}`

#3 kreilly

kreilly

    Member

  • Members
  • PipPip
  • 13 posts

Posted 22 July 2011 - 01:48 PM

Awesome, thanks.

#4 kreilly

kreilly

    Member

  • Members
  • PipPip
  • 13 posts

Posted 22 July 2011 - 02:38 PM

Hi, Unfortunately that did not work at all. The single command added to the css file-- .mcolumn-pad {padding:0px 0px 40px 0px;} didn't actually change anything, no matter how high I put the third number. Then I tried /* @ adjust column padding */ .one-sidebar-right #column-main .mcolumn-pad, .one-sidebar-right #container #content, .two-sidebar-right #column-main .mcolumn-pad, .two-sidebar-right #container #content{ padding: 2em 40px 0 15px; } ... which broke the design completely, and I had to reinstall, because deleting the string above from the style.css file and reuploading did not bring the original layout back. Then I tried /* @ adjust column padding */ .mcolumn-pad {padding-top: 2em; padding-right: 5em;} ... but this didn't change anything either. What's going on here? What am I doing wrong?

#5 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 23 July 2011 - 03:08 PM

Can you please post a link to your website?

#6 kreilly

kreilly

    Member

  • Members
  • PipPip
  • 13 posts

Posted 23 July 2011 - 11:57 PM

Yes, it's www.the-long-view.com. I am actually at WordCamp Boston today and asked a few folks there as well ... adding space to either .scolumn-pad or .mcolumn-pad didn't seem to work ... but maybe I'm missing something.

#7 kreilly

kreilly

    Member

  • Members
  • PipPip
  • 13 posts

Posted 25 July 2011 - 12:45 AM

With WordCamp's help, found the problem! I was missing a close curly bracket in my style.css file that was causing WP to ignore code below it. The code to adjust padding that worked for me .mcolumn-pad { padding-right:70px !important; } Doh! Many thanks :D/