Jump to content


Photo
- - - - -

question. RTL language.what can i change on CSS file for making it RTL supported


This topic has been archived. This means that you cannot reply to this topic.
17 replies to this topic

#1 sahar-parker

sahar-parker

    Member

  • Members
  • PipPip
  • 14 posts

Posted 01 April 2010 - 12:31 PM

Hello! i would like to get some help here please i use iblogPro3 and i've translated the theme to hebrew but that language is typed from right to left and iBlogPro3 doesnt support that (RTL) what can i do? hust help me please tell me what to change in the CSS file btw the theme is Amazing. though i dont know how to add a picture to the post...... :/ thanks again Sahar Parker.

#2 cmunns

cmunns

    Advocate

  • Members

  • 6537 posts

Posted 01 April 2010 - 03:30 PM

To add a picture to the post you have to set the thumbnail. Please refer to the documentation for a little help on that http://pagelines.com/docs As far as aligning the text there may be a few rules you'll have to change, but lets start with adding `body {text-align:right;}` to your custom css code area

#3 sahar-parker

sahar-parker

    Member

  • Members
  • PipPip
  • 14 posts

Posted 01 April 2010 - 03:48 PM

ho ! lol thank you very much that was veryy helpful! thank you Adam!!

#4 sahar-parker

sahar-parker

    Member

  • Members
  • PipPip
  • 14 posts

Posted 01 April 2010 - 03:52 PM

ho but i have a new issue the logo of my site is covered by the small icons (the iphone icons that appears at the top of the site) :/

#5 cmunns

cmunns

    Advocate

  • Members

  • 6537 posts

Posted 01 April 2010 - 04:03 PM

I had a feeling this would happen, for every element that you want moved back to the left simply add .class or #id {text-align:left;} Use this video to help you to identify what the classes or ID's might be http://pagelines.com...ed-with-firebug Also, if you provide a link to your site we will be able to help you further.

#6 sahar-parker

sahar-parker

    Member

  • Members
  • PipPip
  • 14 posts

Posted 01 April 2010 - 04:50 PM

no.. i tried alot but it doesnt put that stupid logo on the left side of the web this is the web http://208.53.158.15/~iphoneil/

#7 cmunns

cmunns

    Advocate

  • Members

  • 6537 posts

Posted 01 April 2010 - 05:22 PM

Try adding `#header a {float:left;}` to your custom css code area.

#8 sahar-parker

sahar-parker

    Member

  • Members
  • PipPip
  • 14 posts

Posted 01 April 2010 - 05:31 PM

bless you !!! thank you very much

#9 sahar-parker

sahar-parker

    Member

  • Members
  • PipPip
  • 14 posts

Posted 01 April 2010 - 06:00 PM

um.. ok i have a few more Question.. um.. first: when somebody submit a comment he gets "404 error" i dont know why... :/ second: how do i make the RSS icon to work? ive never dealt with that before thats all.

#10 sahar-parker

sahar-parker

    Member

  • Members
  • PipPip
  • 14 posts

Posted 01 April 2010 - 07:36 PM

something more important than everything!!! i changed to RTL like you said i added body {text-align:right;} but it doesnt organized at all! when i add some english words all the sentence get unorgenized.. i hope you'll understand what im trying to say/

#11 cmunns

cmunns

    Advocate

  • Members

  • 6537 posts

Posted 02 April 2010 - 07:07 AM

Okay let's tackle this last question first. Where on the site are you seeing the problem (english words look funny), I couldn't find anything? Please point it out and we'll go from there

#12 sahar-parker

sahar-parker

    Member

  • Members
  • PipPip
  • 14 posts

Posted 02 April 2010 - 11:07 AM

no, english words look good but if i write a sentence in hebrew and then i add a word in english all the sentence get wrong. its hard to explain. It even happens when I try to add punctuation to hebrew sentences like: .this is the sentence in hebrew got it? the point is first then comes the sentence in hebrew it should be like this: this is the sentence in hebrew. you see? the point is at the end of the sentence. same about an english word with hebrew example: ??? ?™ ?›?•???‘ ?‘???‘???™?? ?•?’?? in english

#13 sahar-parker

sahar-parker

    Member

  • Members
  • PipPip
  • 14 posts

Posted 02 April 2010 - 11:09 AM

continue: i started with hebrew words then i put english but its got wrong again. the english came at the first and And they destroyed the whole sentence in hebrew.

#14 cmunns

cmunns

    Advocate

  • Members

  • 6537 posts

Posted 02 April 2010 - 04:10 PM

I can't read this, but perhaps this might help solve the problems:

http://he.wordpress.org/

#15 sahar-parker

sahar-parker

    Member

  • Members
  • PipPip
  • 14 posts

Posted 02 April 2010 - 04:24 PM

no : it doesnt help. never mind.. thanks anyway

#16 sahar-parker

sahar-parker

    Member

  • Members
  • PipPip
  • 14 posts

Posted 03 April 2010 - 01:10 AM

ok!! its ok now i added - direction:rtl; can you help me with the others questions? 1: when somebody submit a comment he gets "404 error" i dont know why... :/ 2: how do i make the RSS icon to work? ive never dealt with that before thats all!! those are my last questions finally.

#17 arpowers

arpowers

    Founder

  • Administrators
  • 3270 posts

Posted 03 April 2010 - 07:17 PM

1: when somebody submit a comment he gets "404 error" i dont know why... :/

Not a common problem. Did you try deactivating plugins to see if you still have an issue? Could also be an incomplete upload of theme files.

2: how do i make the RSS icon to work? ive never dealt with that before

Did you select the icon for it? It should just work :)

#18 sahar-parker

sahar-parker

    Member

  • Members
  • PipPip
  • 14 posts

Posted 05 April 2010 - 06:10 PM

alright. thanks you both for helping.. good day