Jump to content


Photo
- - - - -

Search Function Gremlins


  • Please log in to reply
10 replies to this topic

#1 jason1044

jason1044

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 27 June 2011 - 08:51 PM

I'm stumped. Here is our new Pagelines site:

Please Login or Register to see this Hidden Content

Use the search field & search for a word or phrase. Usually, it's all good, you get the results you expected and the site 'looks' OK. Now search for the term 'books'. What happened? The left & righthand columns are wrapping. Any ideas? Thank you Jason

#2 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 28 June 2011 - 02:06 AM

Hm, I'm not sure why the term "books" would throw the layout of. Do you have any custom CSS or plugins you can deactivate? Looks like someone gave the Gremlins water.

#3 jason1044

jason1044

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 28 June 2011 - 04:55 PM

Thanks Catrina. Yes, weird. The only custom CSS I'm using is through the admin panel PLATFORM PRO SETTINGS -> CUSTOM CODE: --------------------------------------- body{} .widget ul li { display: block; list-style: none outside none; padding: 0 0; } body{ color: #3399CC; line-height: 20px; font-size: 11px } blockquote { font-style: italic; margin: 0 0 1em 0; padding: 1em 1em 0.5em; } --------------------------------------- Not much there. As for plugins, just Jetpack. It's a new site, I haven't customized it too much yet. I did notice however that the search term 'BOOKS' does return a TXT file, not just blog posts. I wonder if that has anything to do with the issues? Is there a way to limit search function to only return blog posts? Jason

#4 cmunns

cmunns

    Advocate

  • Members

  • 6537 posts
  • Country: Country Flag

Posted 28 June 2011 - 09:17 PM

strange. yes try to figure out the .text issue..is that plugin relateD?

#5 jason1044

jason1044

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 29 June 2011 - 04:42 PM

OK. It gets weirder. Turns out it isn't the TXT issue, as I just deleted those files from the 'media' folder. You won't see them show up when you search BOOKS anymore. however the issue remains! Try this: Search BOOK, then search BOOKS at

Please Login or Register to see this Hidden Content

BOOK = good BOOKS = not so good, sidebars are wrapping Weird. Any other areas I should look at? Thanks for your help everyone, this forum is great. Jason

#6 cmunns

cmunns

    Advocate

  • Members

  • 6537 posts
  • Country: Country Flag

Posted 29 June 2011 - 09:21 PM

having db connection problems now.

#7 jason1044

jason1044

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 29 June 2011 - 11:09 PM

Thanks Adam. We're migrating servers. NetworkSolutions to --> GreenGeeks. DB Issues should be resolved now. However, the search gremlins remain!

#8 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 30 June 2011 - 02:44 AM

Hm, I was thinking that perhaps you can add the Google Custom search instead but I'm guessing you want to maintain the PlatformPro layout.

#9 jason1044

jason1044

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 06 July 2011 - 07:27 PM

Still having an issue with this. Now several search terms return lefthand-righthand column issues. When using the SEARCH box, terms such as "book" Books" "Paper" return issues with the layout of the site. Any suggestions?

#10 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 07 July 2011 - 02:10 AM

Hm, I am not quite certain. I've never seen this problem before. Have you already tried deactivating the Jetpack plugin?

#11 jason1044

jason1044

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 08 July 2011 - 04:36 PM

Fixed! Thanks Catrina. I deactivated JetPack, and voila, fixed. However, I liked the JetPack plugins, so I simply re-activated them after checking the search field when deactivated and the problem is gone: Deactivate -> re-activate -> Fixed. Thanks everyone. Jason