Jump to content


Photo

image maps in content area


  • Please log in to reply
7 replies to this topic

#1 charles2010

charles2010

    Member

  • Members
  • 20 posts

Posted 08 June 2011 - 08:29 AM

hi there,
I have a problem with some pictures with image maps on them.

I placed some pictures with image maps on my website in the content area. In an earlier version of platform, these maps worked just fine. now they don't work anymore.

I also use a mobile theme plugin, and on that view, the image maps work in the content area.

I use also image maps in the banner region as navigation, and they work fine.

#2 Kate

Kate

    Advocate

  • Members
  • 3039 posts

Posted 08 June 2011 - 02:21 PM

Hi Charles, Which page(s) should have the image map, please? Just to be sure: you're in "HTML" view in the page/post edit screen when you add the image map code, correct?

#3 charles2010

charles2010

    Member

  • Members
  • 20 posts

Posted 09 June 2011 - 07:48 AM

Hi Kate,
the image maps are on every page. Always on the bottom of the content area.

(I put them there so that in the Mobile Theme is a Navigation in the content. Banners, Features and all the other elements are not visible on the mobile theme)

The Image Map Element looks like this.

Yes, I created the code in Dreamweaver and copied it into the HTML View.

Code looks like this.

#4 cmunns

cmunns

    Advocate

  • Members

  • 6537 posts
  • Country: Country Flag

Posted 09 June 2011 - 08:08 PM

Wordpress is probably stripping those tags automatically. http://css-tricks.co...tic-formatting/

#5 charles2010

charles2010

    Member

  • Members
  • 20 posts

Posted 10 June 2011 - 03:08 PM

I just have to copy this four lines of code in the functions.php? In a specific area? Sorry, i have no experience with php. I see there are two functions.php. platformpro or platformbase? thx :)

#6 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 12 June 2011 - 05:04 PM

The functions.php file you need to edit it is the one in PlatformBase, but first make sure PlatformBase is activated. You can access the functions.php file by going to Appearance > Editor > clicking on the file link on the right side. Scroll to the bottom of the functions file and paste those four lines then save.

#7 charles2010

charles2010

    Member

  • Members
  • 20 posts

Posted 14 June 2011 - 03:07 PM

Well, that didn't work :) The strage thing is that there is a map on the picture, that links to the homepage. But it's in an area that I did not define...

#8 cmunns

cmunns

    Advocate

  • Members

  • 6537 posts
  • Country: Country Flag

Posted 14 June 2011 - 07:10 PM

Where is the map showing up? Try color coding each area with styles so you can see what's going on.